CylindricalSurfaceNode Class |
The CylindricalSurfaceNode class represents cylindrical surface geometry tree node.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The CylindricalSurfaceNode type exposes the following members.
Constructors
Name | Description | |
---|---|---|
CylindricalSurfaceNode |
Initializes a new instance of the CylindricalSurfaceNode class.
|
Properties
Name | Description | |
---|---|---|
IsAutomatic |
Gets a value indicating whether this geometry node was automatically generated (returns false if it was originally a user-defined part)
(Inherited from BendSurfaceNode.) | |
Surface |
Gets the cylindrical surface geometry.
|
Methods
Name | Description | |
---|---|---|
AcceptVisitor |
Entry method for the visitor pattern
(Overrides BendSurfaceNodeAcceptVisitor(IGeometryNodeVisitor).) | |
Clone |
Creates a new object that is a copy of the current instance.
(Overrides BendSurfaceNodeClone.) |
See Also