CylindricalSurface Constructor (Arc, Double) |
Initializes a new instance of the CylindricalSurface class from a base arc and a height.
This is the recommended constructor if no intermediate points are desired along the lateral boundaries of the bend surface.
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Parameters
- baseArc
- Type: Tekla.Structures.Geometry3dArc
Arc to form the base of the bend surface - height
- Type: SystemDouble
Height of the surface measured along the normal of the arc, may be positive or negative, but always nonzero
Exceptions
Exception | Condition |
---|---|
ArgumentException | Thrown if the given lengths are invalid |
See Also