CustomPartInputTypeAttribute Class |
The CustomPartInputTypeAttribute class is used for defining the input type.
Based on the type the system will then ask for the correct number of input points in the creation.
The attribute is initialized from the custom attribute
[CustomPartInputType(CustomPartBase.CustomPartInputType.INPUT_1_POINT)]
in the custom part source code.
Inheritance Hierarchy
Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The CustomPartInputTypeAttribute type exposes the following members.
Constructors
Name | Description | |
---|---|---|
CustomPartInputTypeAttribute(Int32) |
The custom attribute uses this to store the input type to the system.
This is not to be used by itself.
| |
CustomPartInputTypeAttribute(CustomPartBaseCustomPartInputType) |
The custom attribute uses this to store the input type to the system.
This is not to be used by itself.
|
Properties
Name | Description | |
---|---|---|
Type |
The custom attribute uses this to store the input type to the system.
This is not to be used by itself.
|
See Also