CustomPart Class

The CustomPart class represents a custom part object in the Tekla Structures model. A custom part is a modeling tool that typically assembles multiple parts to build some type of a beam-like structure, for example a tapered beam or a sandwich panel.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class CustomPart : BaseComponent, 
	IAssemblable

The CustomPart type exposes the following members.

Constructors
  NameDescription
Public methodCustomPart
Creates a new custom part instance.
Public methodCustomPart(Point, Point)
Creates a new custom part instance with the given input.
Top
Properties
  NameDescription
Public propertyPosition
The way the custom part is positioned in the model.
Top
Methods
  NameDescription
Public methodDelete
Deletes the custom part instance with the given identifier from the model database.
(Overrides ModelObjectDelete.)
Public methodGetAssembly
Returns the assembly that the custom part belongs to.
Public methodGetBooleans
Returns an enumerator of all the connected boolean objects.
Public methodGetComponents
Returns an enumerator of all the connected components.
Public methodGetStartAndEndPositions
Returns the start and end points of the custom part.
Public methodInsert
Inserts the custom part into the model database.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the existing custom part in the model database to match the current one.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a custom part from the model database. The custom part identifier must be set.
(Overrides ModelObjectSelect.)
Public methodSetInputPositions
Sets the start and end point of the custom part.
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           CustomPart CPart = new CustomPart();
           CPart.Name = "HPKM39";
           CPart.Number = BaseComponent.CUSTOM_OBJECT_NUMBER;
           CPart.Position.Plane = Position.PlaneEnum.LEFT;
           CPart.Position.PlaneOffset = 10;
           CPart.Position.Depth = Position.DepthEnum.BEHIND;
           CPart.Position.DepthOffset = 30;
           CPart.Position.RotationOffset = 45;
           CPart.Position.Rotation = Position.RotationEnum.TOP;
           CPart.SetInputPositions(new Point(100, 0, 0), new Point(300, 0, 0));
           CPart.SetAttribute("P2a", "TEST");
           CPart.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next