CustomObservableCollectionT Class

CustomObservableCollection for synchronizing UI controls.
Inheritance Hierarchy
SystemObject
  System.Collections.ObjectModelCollectionT
    System.Collections.ObjectModelObservableCollectionT
      Tekla.Structures.Dialog.UIControlsCustomObservableCollectionT

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public class CustomObservableCollection<T> : ObservableCollection<T>

Type Parameters

T

The CustomObservableCollectionT type exposes the following members.

Constructors
Methods
  NameDescription
Public methodRepopulate
CustomObservableCollection repopulator, sends notification about property and collection change.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next