CurvedSectionMark Class

The CurvedSectionMark class defines a drawing object that illustrates a curved section in a specific view. In contrast to straight section mark, the curved section mark can only be inserted as a result of creating a curved section view.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class CurvedSectionMark : SectionMarkBase

The CurvedSectionMark type exposes the following members.

Properties
  NameDescription
Public propertyMiddlePoint
The middle arc point of a curved section mark.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides SectionMarkBaseIsEqual(Object).)
Top
Examples
The following code modifies a curved section mark in the current drawing:
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;

public class CurvedSectionMarkExample
{
    public void CurvedSectionMarkModify()
    {
        DrawingHandler myDrawingHandler = new DrawingHandler();
        DrawingObjectSelector dos = myDrawingHandler.GetDrawingObjectSelector();
        DrawingObjectEnumerator allObjectsOnSheet = dos.GetSelected();
        while (allObjectsOnSheet.MoveNext())
        {
            if (allObjectsOnSheet.Current is Tekla.Structures.Drawing.CurvedSectionMark)
            {
                CurvedSectionMark sectionMark = allObjectsOnSheet.Current as Tekla.Structures.Drawing.CurvedSectionMark;
                sectionMark.Attributes.LineWidthOffsetLeft = 5;
                sectionMark.Attributes.LineWidthOffsetRight = 5;
                sectionMark.Modify();
            }
        }
    }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next