CurvedDimensionSetRadialCurvedDimensionSetRadialAttributes Class |
The CurvedDimensionSetRadialAttributes class contains the attributes for managing all the attributes
of the curved dimension with radial reference lines.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingCurvedDimensionSetBaseCurvedDimensionSetBaseAttributes
Tekla.Structures.DrawingCurvedDimensionSetRadialCurvedDimensionSetRadialAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingCurvedDimensionSetBaseCurvedDimensionSetBaseAttributes
Tekla.Structures.DrawingCurvedDimensionSetRadialCurvedDimensionSetRadialAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The CurvedDimensionSetRadialCurvedDimensionSetRadialAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
CurvedDimensionSetRadialCurvedDimensionSetRadialAttributes |
Creates a new curved dimension set radial attributes instance which loads standard attributes.
| |
CurvedDimensionSetRadialCurvedDimensionSetRadialAttributes(Boolean) |
Creates a new curved dimension set radial attributes instance which loads standard attributes.
If it set to true attributes won't be lodaded. | |
CurvedDimensionSetRadialCurvedDimensionSetRadialAttributes(String) |
Creates a new curved dimension set radial attributes instance that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
Arrowhead |
The arrowhead attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) | |
Color |
The color of the dimension line.
(Inherited from DimensionSetBaseAttributes.) | |
CurvedDimensionType |
The curved dimension type.
| |
DimensionType |
The dimension type.
| |
Format |
The format attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) | |
Placing |
The placing attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) | |
Text |
The text attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) | |
TransparentBackground |
The dimension text background transparency. (transparent/opaque)
(Inherited from DimensionSetBaseAttributes.) | |
TrueColor |
The true color (RGB enabled) of the dimension line.
(Inherited from DimensionSetBaseAttributes.) |
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) | |
LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |
See Also