CurvedDimensionSetHandler Class |
The CurvedDimensionSetHandler class contains operations for creating curved dimension sets.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The CurvedDimensionSetHandler type exposes the following members.
Constructors
Name | Description | |
---|---|---|
CurvedDimensionSetHandler | Initializes a new instance of the CurvedDimensionSetHandler class |
Methods
Name | Description | |
---|---|---|
CreateCurvedDimensionSetOrthogonal(ViewBase, Point, Point, Point, PointList, Double) |
Creates a curved dimension set with orthogonal reference lines
from the specified points and inserts it to the database.
| |
CreateCurvedDimensionSetOrthogonal(ViewBase, Point, Point, Point, PointList, Double, CurvedDimensionSetOrthogonalCurvedDimensionSetOrthogonalAttributes) |
Creates a curved dimension set with orthogonal reference lines
from the specified points and inserts it to the database.
| |
CreateCurvedDimensionSetRadial(ViewBase, Point, Point, Point, PointList, Double) |
Creates a curved dimension set from the specified points and inserts it to the database.
Uses the default attributes.
| |
CreateCurvedDimensionSetRadial(ViewBase, Point, Point, Point, PointList, Double, CurvedDimensionSetRadialCurvedDimensionSetRadialAttributes) |
Creates a curved dimension set from the specified points and inserts it to the database.
|
See Also