CurvedDimensionSetBase Class |
The CurvedDimensionSetBase class is the base class for curved dimension sets which are defined by
an arc and a point list.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingDimensionSetBase
Tekla.Structures.DrawingCurvedDimensionSetBase
Tekla.Structures.DrawingCurvedDimensionSetOrthogonal
Tekla.Structures.DrawingCurvedDimensionSetRadial
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingDimensionSetBase
Tekla.Structures.DrawingCurvedDimensionSetBase
Tekla.Structures.DrawingCurvedDimensionSetOrthogonal
Tekla.Structures.DrawingCurvedDimensionSetRadial
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The CurvedDimensionSetBase type exposes the following members.
Properties
Name | Description | |
---|---|---|
ArcPoint1 |
Gets the first arc point.
| |
ArcPoint2 |
Gets the second arc point.
| |
ArcPoint3 |
Gets the third arc point.
| |
Attributes |
Gets or sets the dimension set attributes.
| |
DimensionPoints |
Gets a list of the dimension points.
| |
Distance |
Gets the distance.
The distance is measured in paper millimeters.
Methods
Name | Description | |
---|---|---|
Delete |
Deletes the dimension set and its child dimensions from the database.
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
Insert |
Curved dimensions are created using the curved dimension set handler.
Modify |
Modifies the existing dimension set in the database.
(Overrides DatabaseObjectModify.) | |
Select |
Selects the dimension set from the database.
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
See Also