CrossSectionPoint Class |
The CrossSectionPoint class defines a point with possible chamfering information
Inheritance Hierarchy
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The CrossSectionPoint type exposes the following members.
Constructors
Name | Description | |
---|---|---|
CrossSectionPoint |
Creates a new cross section point instance.
|
Properties
Methods
Name | Description | |
---|---|---|
CompareTo |
Compares two points. To use binarysearch somekind of sorting should be used.
(Inherited from Point.) | |
Equals |
Returns true if the current object and the given object are equal.
(Inherited from Point.) | |
GetHashCode |
Returns a hash code for the point.
Notice, in extremely rare cases, you might not get the same
hash code for two points even though they are considered equal! This
should, however, happen only in extremely rare cases!
(Inherited from Point.) | |
ToString |
Formats the point into a string.
(Inherited from Point.) | |
Translate |
Translates the point using the given vector.
(Inherited from Point.) | |
Zero |
Zeros all the members of the point.
(Inherited from Point.) |
Fields
Name | Description | |
---|---|---|
X |
The X-coordinate of the point.
(Inherited from Point.) | |
Y |
The Y-coordinate of the point.
(Inherited from Point.) | |
Z |
The Z-coordinate of the point.
(Inherited from Point.) |
See Also