OperationCreateShapeFromGeometry Method

Create a new shape in the shape catalog, based on the part geometry.

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static string CreateShapeFromGeometry(
	Part originalPart
)

Parameters

originalPart
Type: Tekla.Structures.ModelPart
Original part

Return Value

Type: String
The newly created shape name, or empty string on failure
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown if the originalPart is null.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next