RectangleBoundingBoxCreateRectangleBoundingBox Method

Creates a new RectangleBoundingBox with the given values.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static RectangleBoundingBox CreateRectangleBoundingBox(
	Point CenterPoint,
	double Width,
	double Height,
	double AngleToAxis
)

Parameters

CenterPoint
Type: Tekla.Structures.Geometry3dPoint
The center point of the bounding box.
Width
Type: SystemDouble
The width of the bounding box.
Height
Type: SystemDouble
The height of the bounding box.
AngleToAxis
Type: SystemDouble
The angle of the box (compared to the X-axis).

Return Value

Type: RectangleBoundingBox
The created rectangle bounding box.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next