OperationCreateMISFileFromAll Method

Creates MIS files from all parts using the given file name.

See Tekla Structures Help for more information about MIS files.

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static bool CreateMISFileFromAll(
	OperationMISExportTypeEnum MISType,
	string FileName
)

Parameters

MISType
Type: Tekla.Structures.Model.OperationsOperationMISExportTypeEnum
The type of the MIS export.
FileName
Type: SystemString
The name of the MIS file to be used in creation.

Return Value

Type: Boolean
True if the MIS files are created, false if the numbering is not up-to-date or the used configuration is wrong.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when the FileName is null.
ArgumentExceptionThrown when the FileName is not defined.
Examples
using Tekla.Structures.Model.Operations;
using System.Windows.Forms;

public class Example
{
       public void Example1()
       {
           if (Operation.CreateMISFileFromAll(Operation.MISExportTypeEnum.STEEL2000, "myExport.st2000"))
               MessageBox.Show("MIS creation successful");
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next