RebarSpacingCreate Method (RebarSpacingSpacingType, RebarSpacingOffset, RebarSpacingOffset, Double)

Create a spacing which is defined by a single distance.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static RebarSpacing Create(
	RebarSpacingSpacingType type,
	RebarSpacingOffset startOffset,
	RebarSpacingOffset endOffset,
	double distance
)

Parameters

type
Type: Tekla.Structures.ModelRebarSpacingSpacingType
The type of spacing.
startOffset
Type: Tekla.Structures.ModelRebarSpacingOffset
The start offset.
endOffset
Type: Tekla.Structures.ModelRebarSpacingOffset
The end offset.
distance
Type: SystemDouble
The spacing distance.

Return Value

Type: RebarSpacing
A RebarSpacing instance if the given type and distance are valid.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next