RebarSpacingCreate Method (RebarSpacingOffset, RebarSpacingOffset, IEnumerableRebarSpacingExactSpacingElement, RebarSpacingExactSpacingValidation)

Creates an exact spacing if the given elements are valid.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static RebarSpacing Create(
	RebarSpacingOffset startOffset,
	RebarSpacingOffset endOffset,
	IEnumerable<RebarSpacingExactSpacingElement> elements,
	out RebarSpacingExactSpacingValidation validation
)

Parameters

startOffset
Type: Tekla.Structures.ModelRebarSpacingOffset
The start offset.
endOffset
Type: Tekla.Structures.ModelRebarSpacingOffset
The end offset.
elements
Type: System.Collections.GenericIEnumerableRebarSpacingExactSpacingElement
The elements.
validation
Type: Tekla.Structures.ModelRebarSpacingExactSpacingValidation
Returns a value indicating the validity of the elements.

Return Value

Type: RebarSpacing
A RebarSpacing instance.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next