InputDefinitionFactoryCreateInputDefinition Method (ViewBase, Point, Point)

Creates a two-point input definition.

Namespace:  Tekla.Structures.Drawing.Tools
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static DrawingPluginBaseInputDefinition CreateInputDefinition(
	ViewBase view,
	Point point1,
	Point point2
)

Parameters

view
Type: Tekla.Structures.DrawingViewBase
The view to be used in the input.
point1
Type: Tekla.Structures.Geometry3dPoint
The first point to be used in the input.
point2
Type: Tekla.Structures.Geometry3dPoint
The second point to be used in the input.

Return Value

Type: DrawingPluginBaseInputDefinition
The input definition.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next