DrawingCreatorCreateDrawings Method (AutoDrawingRule, ListIdentifier, AutoDrawingsStatusEnum) |
Creates drawings using the AutoDrawing tool of Tekla Structures.
Namespace: Tekla.Structures.Drawing.Automation
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static bool CreateDrawings( AutoDrawingRule Rule, List<Identifier> aModelObjectIdentifier, out AutoDrawingsStatusEnum OperationStatus )
Parameters
- Rule
- Type: Tekla.Structures.Drawing.AutomationAutoDrawingRule
The AutoDrawing rule to be used. - aModelObjectIdentifier
- Type: System.Collections.GenericListIdentifier
The model object identifier list to be used. Part identifiers to create single part drawings or assembly identifiers to create assembly drawings. - OperationStatus
- Type: Tekla.Structures.Drawing.AutomationAutoDrawingsStatusEnum
The operation status to be used.
Return Value
Type: BooleanTrue on success.
See Also