StraightDimensionSetHandlerCreateDimensionSet Method (ViewBase, PointList, Vector, Double, StraightDimensionSetStraightDimensionSetAttributes) |
Creates straight dimensions and combines them to one straight dimension set. Returns null if fails.
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public StraightDimensionSet CreateDimensionSet( ViewBase View, PointList DimensionPoints, Vector UpDirection, double Distance, StraightDimensionSetStraightDimensionSetAttributes Attributes )
Parameters
- View
- Type: Tekla.Structures.DrawingViewBase
The view to be used. - DimensionPoints
- Type: Tekla.Structures.DrawingPointList
The dimension points to be used. - UpDirection
- Type: Tekla.Structures.Geometry3dVector
The direction from the dimension points to the dimension line. - Distance
- Type: SystemDouble
The distance in paper millimeters taken from the first dimension point to the dimension line. - Attributes
- Type: Tekla.Structures.DrawingStraightDimensionSetStraightDimensionSetAttributes
The attributes to be used.
Return Value
Type: StraightDimensionSetThe created straight dimension set or null if fails.
See Also