CoordinateSystem Constructor (Point, Vector, Vector)

Instantiates a coordinate system with the given origin, X-axis and Y-axis.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public CoordinateSystem(
	Point Origin,
	Vector AxisX,
	Vector AxisY
)

Parameters

Origin
Type: Tekla.Structures.Geometry3dPoint
The origin for the coordinate system.
AxisX
Type: Tekla.Structures.Geometry3dVector
The X-axis for the coordinate system.
AxisY
Type: Tekla.Structures.Geometry3dVector
The Y-axis for the coordinate system.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next