ConnectionStatusEnum Enumeration |
The status type defines what the status of a connection or a detail is.
In the model the color of the symbol (green, yellow, red) indicates the status.
Namespace: Tekla.Structures
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
STATUS_UNKNOWN | 0 | The status is unknown. | |
STATUS_OK | 1 | The status is ok and the symbol color is green. | |
STATUS_WARNING | 2 | The status indicates a warning and the symbol color is yellow. | |
STATUS_ERROR | 3 | The status indicates an error and the symbol color is red. |
See Also