Connection Class |
The Connection class contains methods related to connections.
A connection is a drawing object derived from a model object.
It represents a drawing connection that has a reference to the
actual connection in the model database.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingModelObject
Tekla.Structures.DrawingConnection
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingModelObject
Tekla.Structures.DrawingConnection
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The Connection type exposes the following members.
Properties
Name | Description | |
---|---|---|
ModelIdentifier |
The database identifier of the model object in the model database.
By using this identifier, it is possible to select the actual object
Methods
Name | Description | |
---|---|---|
Delete |
Deletes the drawing connection from the current drawing database.
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
Insert |
NOT YET IMPLEMENTED.
(Overrides DatabaseObjectInsert.) | |
IsEqual |
Compares the current object with an object of the same type.
Modify |
NOT YET IMPLEMENTED.
(Overrides DatabaseObjectModify.) | |
Select |
Selects the drawing connection from the current drawing database.
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
See Also