ConicalSurface Constructor (Arc, Double, Double)

Initializes a new instance of the ConicalSurface class from a base arc, a height and a radius at the top. This is the recommended constructor if no intermediate points are desired along the lateral boundaries of the bend surface.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public ConicalSurface(
	Arc baseArc,
	double height,
	double radiusAtHeight
)

Parameters

baseArc
Type: Tekla.Structures.Geometry3dArc
Arc to form the base of the bend surface
height
Type: SystemDouble
Height of the surface measured along the normal of the arc, may be positive or negative, but always nonzero
radiusAtHeight
Type: SystemDouble
Radius of the arc located at the given height. Must be positive
Exceptions
ExceptionCondition
ArgumentExceptionThrown if the given lengths are invalid
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next