ComponentItemEnumerator Class

The ComponentItemEnumerator class allows to loop through the component catalog items.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsComponentItemEnumerator

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class ComponentItemEnumerator : IEnumerator

The ComponentItemEnumerator type exposes the following members.

Properties
  NameDescription
Public propertyCurrent
Returns a component item instance of the current element.
Top
Methods
  NameDescription
Public methodGetSize
Returns the total amout of items.
Public methodMoveNext
Moves to the next item in the enumerator.
Public methodReset
Resets the enumerator to the beginning.
Top
Examples
The following example returns true if an item with the name EndPlate and with the number 144 has been found:
using Tekla.Structures.Catalogs;

public class Example
{
       public bool Example1()
       {
           bool Result = false;

           CatalogHandler CatalogHandler = new CatalogHandler();

           if (CatalogHandler.GetConnectionStatus())
           {
               ComponentItemEnumerator ComponentItemEnumerator = CatalogHandler.GetComponentItems();

               while (ComponentItemEnumerator.MoveNext())
               {
                   ComponentItem ComponentItem = ComponentItemEnumerator.Current as ComponentItem;

                   if (ComponentItem.Name == "EndPlate" && ComponentItem.Number == 144)
                   {
                       Result = true;
                       break;
                   }
               }
           }

           return Result;
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next