ComponentCatalog Class |
The ComponentCatalog class represents a group of controls to select components
using the component catalog.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsComponentCatalog
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsComponentCatalog
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The ComponentCatalog type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ComponentCatalog |
Initializes a new instance of the ComponentCatalog class.
|
Properties
Name | Description | |
---|---|---|
SelectedComponentType |
Gets or sets the selected component type in the control.
| |
SelectedName |
Gets or sets the selected component name in the control.
| |
SelectedNumber |
Gets or sets the selected component number in the control.
|
Events
Name | Description | |
---|---|---|
SelectClicked |
The SelectClicked event is raised when the Select button is clicked.
| |
SelectionDone |
The SelectionDone event is raised when the selection has been done.
|
See Also