AABBCollide Method |
Checks if the current axis-aligned 3d bounding box collides with
another given axis-aligned 3d bounding box. Both axis-aligned 3d
bounding boxes need to be in the same coordinate system or in the
same workplane, so that they are defined using the same axes.
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Parameters
- Other
- Type: Tekla.Structures.Geometry3dAABB
Another axis-aligned 3d bounding box to be used in the collision check.
Return Value
Type: BooleanTrue if the axis-aligned 3d bounding boxes collide.
See Also