OBBClosestPointTo Method (Point) |
Calculates the closest point in OBB to given point.
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Parameters
- point
- Type: Tekla.Structures.Geometry3dPoint
Point to calculate against.
Return Value
Type: PointClosest point in OBB to given point.
Exceptions
Exception | Condition |
---|---|
ArgumentNullException | Thrown when null is assigned to the point parameter. |
See Also