![]() | ClashCheckHandler Class |
The ClashCheckHandler class contains clash check methods.

Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63

The ClashCheckHandler type exposes the following members.

Name | Description | |
---|---|---|
![]() | GetIntersectionBoundingBoxes |
Get a list of bounding boxes (AABB) of the clashing volumes of two objects.
|
![]() | RunClashCheck |
Starts the clash checking. Uses advanced options sa option values.
|
![]() | RunClashCheckWithOptions(Boolean, Boolean, Double, Boolean) |
Starts the clash checking with options.
|
![]() | RunClashCheckWithOptions(Boolean, Boolean, Boolean, Double, Boolean) |
Starts the clash checking with options.
|
![]() | StopClashCheck |
Stops the clash checking.
|

using Tekla.Structures.Model; public class Example { public void Exmaple1() { Model MyModel = new Model(); ClashCheckHandler ClashCheck = MyModel.GetClashCheckHandler(); ClashCheck.RunClashCheck(); ClashCheck.StopClashCheck(); } }