ClashCheckData Class

The ClashCheckData class presents information about the detected clash. It is instantiated inside the onClashDetected method. The objects store the identifiers and type of the clash to be passed on to event subscribers.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelClashCheckData

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public class ClashCheckData

The ClashCheckData type exposes the following members.

Constructors
  NameDescription
Public methodClashCheckData
Initializes a new instance of the ClashCheckData class
Top
Properties
  NameDescription
Public propertyObject1
Gets the first clashing object.
Public propertyObject2
Gets the second clashing object.
Public propertyOverlap
Gets the overlap of the clash. Only applies to clashes of type CLASH_TYPE_CLASH.
Public propertyType
Gets the type of the clash.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next