Circle Constructor (ViewBase, Point, Double, CircleCircleAttributes) |
Creates a new circle instance with a center point and a radius using the given attributes.
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public Circle( ViewBase view, Point centerPoint, double radius, CircleCircleAttributes attributes )
Parameters
- view
- Type: Tekla.Structures.DrawingViewBase
The view to be used. - centerPoint
- Type: Tekla.Structures.Geometry3dPoint
The center point to be used. - radius
- Type: SystemDouble
The radius to be used. - attributes
- Type: Tekla.Structures.DrawingCircleCircleAttributes
The circle attributes to be used.
See Also