CatalogObjectTypeEnum Enumeration |
The catalog object type.
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
PART | 1 | The part type. | |
STEEL_BEAM | 2 | The steel beam type. | |
STEEL_COLUMN | 3 | The steel column type. | |
STEEL_ORTHOGONAL_BEAM | 4 | The steel orthogonal beam type. | |
STEEL_TWIN_PROFILE_BEAM | 5 | The steel twin profile beam type. | |
STEEL_CONTOUR_PLATE | 6 | The steel contour plate type. | |
STEEL_FOLDED_PLATE | 7 | The steel folded plate type. | |
CONCRETE_BEAM | 8 | The concrete beam type. | |
CONCRETE_COLUMN | 9 | The concrete column type. | |
CONCRETE_PAD_FOOTING | 10 | The concrete pad footing type. | |
CONCRETE_STRIP_FOOTING | 11 | The concrete strip footing type. | |
CONCRETE_PANEL | 12 | The concrete panel type. | |
CONCRETE_SLAB | 13 | The concrete slab type. | |
REINFORCING_BAR | 14 | The reinforcing bar type. | |
SURFACING | 15 | The surfacing type. | |
WELD | 16 | The weld type. | |
BOLT | 17 | The bolt type. | |
STEEL_ASSEMBLY | 18 | The steel assembly type. | |
PRECAST_CONCRETE_ASSEMBLY | 19 | The precast concrete assembly type. | |
INSITU_CONCRETE_ASSEMBLY | 20 | The in situ concrete assembly type. | |
POUR_OBJECT | 21 | The pour object type. | |
POUR_BREAK | 22 | The pour break type. | |
GRID | 23 | The grid type. | |
PROJECT | 24 | The project type. | |
PHASE | 25 | The phase type. | |
TASK | 26 | The task type. | |
REFERENCE_MODEL | 27 | The reference model type. | |
REFERENCE_MODEL_OBJECT | 28 | The reference model object type. | |
SINGLE_PART_DRAWING | 29 | The single part drawing type. | |
ASSEMBLY_DRAWING | 30 | The assembly drawing type. | |
GA_DRAWING | 31 | The general arrangement drawing type. | |
MULTI_DRAWING | 32 | The multidrawing type. | |
CAST_UNIT_DRAWING | 33 | The cast unit drawing type. | |
BENT_PLATE | 34 | The bent plate type. | |
STEEL_BREP_PART | 35 | The steel brep part type. | |
CONCRETE_BREP_PART | 36 | The concrete brep part type. | |
CHAMFER_OBJECT | 37 | The chanfer object type. | |
SURFACE_OBJECT | 38 | The surface object type. | |
GRID_PLANE | 39 | The grid plane type. | |
STEEL_SPIRAL_BEAM | 40 | The steel helix part type. | |
CONCRETE_SPIRAL_BEAM | 41 | The concrete helix part type. | |
POUR_UNIT | 42 | The pour unit type. | |
STEEL_LOFTED_PLATE | 43 | The steel lofted plate part type. | |
CONCRETE_LOFTED_SLAB | 44 | The concrete lofted slab part type. | |
BUILDING_SPACE | 45 | The building space object type. |
See Also