CatalogHandler Class |
The CatalogHandler class is a class from which the user can query catalog instances.
Inheritance Hierarchy
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The CatalogHandler type exposes the following members.
Constructors
Name | Description | |
---|---|---|
CatalogHandler |
Creates a new catalog handler instance.
|
Methods
Name | Description | |
---|---|---|
ExportProfileItems |
Exports the profile items in the profile database to given path and file name.
Currently library profiles, sketch profiles and clb profiles are supported.
Library profiles are exported to *.lis format.
Sketch profiles are exported to *.uel format.
Clb profiles are exported to *.clb format.
If profiles are not available, export fails.
If path is empty, export fails.
If file name is empty, export fails.
| |
GetBoltItems |
Returns an enumerator of all bolt items.
| |
GetComponentItems |
Returns an enumerator of all component items.
| |
GetConnectionStatus |
Returns true if a proper connection to the Tekla Structures process has been established.
Currently, there's no way to re-establish the connection.
| |
GetDrawingItems |
Returns an enumerator of all drawing items.
| |
GetLibraryProfileItems |
Returns an enumerator of library profile items.
| |
GetMaterialItems |
Returns an enumerator of all material items.
| |
GetMaterialMarketSizes |
Returns an enumerator of all material marketsizes.
Data is read from XS_PROFDB\marketsizes.dat file.
| |
GetMeshItems |
Returns an enumerator of mesh items.
| |
GetParametricProfileItems |
Returns an enumerator of parametric profile items.
| |
GetPrinterItems |
Returns an enumerator of all printer items.
| |
GetProfileItems |
Returns an enumerator of all profile items.
| |
GetRebarItems |
Returns an enumerator of rebar items.
| |
GetShapeItems |
Returns an enumerator of all shape items.
| |
GetUserPropertyItems |
Returns an enumerator of all user property items.
| |
GetUserPropertyItems(CatalogObjectTypeEnum) |
Returns an enumerator of user property items of the given object type.
| |
ImportBoltItems |
Imports bolt items and their assembly information (*.bass) from folder to bolt assembly catalog and bolt catalog.
Import overrides the existing bolts in the catalog without any warnings.
| |
ImportCustomComponentItems |
Imports custom component items (*.uel) from path to component catalog.
Import overrides the existing custom components in the catalog without any warnings.
| |
ImportDrawingItems |
Imports drawing setting items (*.tsds) from specified folder to model folder.
Import throws exception if model is not open.
Import overrides the existing drawing items in the catalog without any warnings.
| |
ImportLibraryProfileItems |
Imports library profile items (*.lis) from folder to profile catalog.
Import overrides the existing profiles in the catalog without any warnings.
| |
ImportMaterialItems |
Imports material items (*.lis) from folder to material catalog.
Import overrides the existing materials in the catalog without any warnings.
| |
ImportMeshItems |
Imports mesh items (*.mexp) from folder to mesh catalog.
Import overrides the existing mesh item in the catalog without any warnings.
| |
ImportParametricProfileItems |
Imports parametric profile items (*.uel) from folder to profile catalog.
Import overrides the existing profiles in the catalog without any warnings.
| |
ImportRebarItems |
Imports rebar items (*.rexp) from folder to reinforcement catalog.
Import overrides the existing rebar item in the catalog without any warnings.
| |
ImportShapeItems |
Imports shape geometry items (*.tsc) from specified folder.
Import throws exception if model is not open.
Import overrides the existing shape items in the catalog without any warnings.
| |
SaveProfileDatabase |
Saves the profile database.
|
See Also