CastUnitDrawing Constructor (Identifier, CastUnitDrawingCastUnitDrawingCreationType, String)

Instantiates a new cast unit drawing with given attributes for a given cast unit.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public CastUnitDrawing(
	Identifier castUnitIdentifier,
	CastUnitDrawingCastUnitDrawingCreationType castUnitDrawingCreationType,
	string AttributeFile
)

Parameters

castUnitIdentifier
Type: Tekla.StructuresIdentifier
The identifier of the model object cast unit.
castUnitDrawingCreationType
Type: Tekla.Structures.DrawingCastUnitDrawingCastUnitDrawingCreationType
Specifies the cast unit drawing creation type (by cast unit id or by cast unit position).
AttributeFile
Type: SystemString
The filename of the attributes file.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next