BooleanConverter Class |
The BooleanConverter class converts types to and from the boolean type.
Inheritance Hierarchy
Namespace: Tekla.Structures.Datatype
Assembly: Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The BooleanConverter type exposes the following members.
Constructors
Name | Description | |
---|---|---|
BooleanConverter | Initializes a new instance of the BooleanConverter class |
Methods
Name | Description | |
---|---|---|
CanConvertFrom |
Checks whether the conversion can be made from the source type to the boolean type.
(Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).) | |
CanConvertTo |
Checks whether the conversion can be made from the boolean type to the destination type.
(Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).) | |
ConvertFrom |
Converts an object from the given culture to the boolean type.
(Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).) | |
ConvertTo |
Converts an object from the boolean type to the given destination type.
(Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).) |
See Also