BoltGroup Class |
The BoltGroup class is an abstract base class for all bolt shapes, such as array, circle and XY list.
See the Tekla Structures help file for further information about the attributes.
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBoltGroup
Tekla.Structures.ModelBoltArray
Tekla.Structures.ModelBoltCircle
Tekla.Structures.ModelBoltXYList
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBoltGroup
Tekla.Structures.ModelBoltArray
Tekla.Structures.ModelBoltCircle
Tekla.Structures.ModelBoltXYList
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The BoltGroup type exposes the following members.
Constructors
Properties
Name | Description | |
---|---|---|
BlindHoleDepth |
Gets or sets the blind hole depth.
| |
Bolt |
Indicates whether the instance is a bolt or just a hole.
| |
BoltHolesAttributes |
The bolt holes attributes.
| |
BoltPositions |
Gets the single bolt positions.
All the bolt positions are in the XY-plane defined by the bolt group coordinate
system. The given positions are in relation to the transformation plane
in which the bolt group was selected.
| |
BoltSize |
The size of the bolts in the group.
| |
BoltStandard |
The standard of the bolt group.
| |
BoltType |
The type of the bolt group.
| |
ConnectAssemblies | Defines whether to connect a part or an assembly as a secondary part (false) or as a sub-assembly (true). | |
CutLength |
The cut length.
| |
EndPointOffset |
The end point offset values of the bolt group.
| |
ExtraLength |
The extra length for the bolts.
| |
FirstPosition |
The first position point.
| |
Hole1 |
Indicates whether the hole 1 is used.
| |
Hole2 |
Indicates whether the hole 2 is used.
| |
Hole3 |
Indicates whether the hole 3 is used.
| |
Hole4 |
Indicates whether the hole 4 is used.
| |
Hole5 |
Indicates whether the hole 5 is used.
| |
HoleType |
The special hole type: oversized, slotted, blind or no hole.
| |
Identifier |
The identifier of the object.
(Inherited from Object.) | |
IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) | |
Length |
The length. An extra variable that is only set when the bolt group is made of studs instead of bolts.
| |
ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) | |
Nut1 |
Indicates whether the nut 1 is used in the assembly.
| |
Nut2 |
Indicates whether the nut 2 is used in the assembly.
| |
OtherPartsToBolt |
The other parts to be bolted (read-only).
| |
PartToBeBolted |
The part to be bolted.
| |
PartToBoltTo |
The part to bolt to.
| |
PlainHoleType |
Gets or sets the plain hole type.
| |
Position |
The position attributes.
| |
RotateSlots |
Gets or sets the rotation of the slots: odd, even or parallel.
| |
SecondPosition |
The second position point.
| |
SlotOffsetX |
Gets or sets the slotted hole offset X.
| |
SlotOffsetY |
Gets or sets the slotted hole offset Y.
| |
SlottedHoleX |
Gets or sets the X allowance of the slotted hole.
| |
SlottedHoleY |
Gets or sets the Y allowance of the slotted hole.
| |
StartPointOffset |
The start point offset values of the bolt group.
| |
ThreadInMaterial |
Whether the thread goes inside the materal or not.
| |
Tolerance |
The hole tolerance.
| |
Washer1 |
Indicates whether the washer 1 is used in the assembly.
| |
Washer2 |
Indicates whether the washer 2 is used in the assembly.
| |
Washer3 |
Indicates whether the washer 3 is used in the assembly.
|
Methods
Name | Description | |
---|---|---|
AddOtherPartToBolt |
Adds the given part to the list of the other parts that should be bolted.
| |
CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) | |
Delete |
Deletes the instance from the model database.
(Inherited from ModelObject.) | |
Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) | |
GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) | |
GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) | |
GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) | |
GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) | |
GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) | |
GetFatherPour |
Returns the pour that the bolt group is associated to.
| |
GetFatherPourUnit |
Returns the pour unit that the bolt group is associated to.
| |
GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) | |
GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) | |
GetOtherPartsToBolt |
Returns an array list containing all the other parts that are bolted.
| |
GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) | |
GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) | |
GetSolid |
Method for getting the solid information of the bolt group.
| |
GetSolid(Boolean) |
Method for getting the solid information of the bolt group.
| |
GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) | |
Insert |
Inserts the model object instance into the model database.
(Inherited from ModelObject.) | |
Modify |
Modifies the model instance in the model database.
(Inherited from ModelObject.) | |
RemoveOtherPartToBolt |
Removes the given part from the list of the other bolted parts.
| |
Select |
Selects the model object instance from the model database.
(Inherited from ModelObject.) | |
SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) | |
SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) | |
SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) | |
SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |
See Also