BoltCatalogStandard Class |
The BoltCatalogStandard class represents a control to select the bolt standard
using the bolt catalog.
Bolt catalog controls always need to be in pairs, meaning in every dialog there has to be a BoltCatalogStandard and a BoltCatalogSize control.
The property BoltCatalogStandard.LinkedBoltCatalogSize sets to which BoltCatalogSize the control is linked.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsListControl
System.Windows.FormsComboBox
Tekla.Structures.Dialog.UIControlsBoltCatalogStandard
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsListControl
System.Windows.FormsComboBox
Tekla.Structures.Dialog.UIControlsBoltCatalogStandard
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The BoltCatalogStandard type exposes the following members.
Constructors
Name | Description | |
---|---|---|
BoltCatalogStandard |
Initiates a new instance of the control.
|
Properties
Name | Description | |
---|---|---|
LinkedBoltCatalogSize |
The BoltCatalogSize control linked to the BoltCatalogStandard control.
Bolt catalog controls always need to be in pairs, meaning in every dialog
there has to be a BoltCatalogStandard and a BoltCatalogSize control.
|
See Also