BindPropertyNameEditor Class |
The BindPropertyNameEditor class provides a user interface for selecting a property for the attribute binding.
Inheritance Hierarchy
Namespace: Tekla.Structures.Dialog
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The BindPropertyNameEditor type exposes the following members.
Constructors
Name | Description | |
---|---|---|
BindPropertyNameEditor | Initializes a new instance of the BindPropertyNameEditor class |
Methods
Name | Description | |
---|---|---|
EditValue |
Edits the specified object's value using the editor style indicated by the GetEditStyle method.
(Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).) | |
GetEditStyle |
Gets the editor style used by the EditValue method.
(Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).) |
See Also