BinaryFilterExpression Constructor (NumericFilterExpression, NumericOperatorType, NumericConstantFilterExpression)

Initializes a new instance of the BinaryFilterExpression class.

Namespace:  Tekla.Structures.Filtering
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public BinaryFilterExpression(
	NumericFilterExpression Left,
	NumericOperatorType Oper,
	NumericConstantFilterExpression Right
)

Parameters

Left
Type: Tekla.Structures.FilteringNumericFilterExpression
The left operand of the filter expression.
Oper
Type: Tekla.Structures.FilteringNumericOperatorType
The operator of the filter expression.
Right
Type: Tekla.Structures.FilteringNumericConstantFilterExpression
The right operand of the filter expression.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when a null filter expression is specified.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next