BinaryFilterExpression Constructor (BooleanFilterExpression, BooleanOperatorType, BooleanConstantFilterExpression) |
Initializes a new instance of the BinaryFilterExpression class.
Namespace: Tekla.Structures.Filtering
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public BinaryFilterExpression( BooleanFilterExpression Left, BooleanOperatorType Oper, BooleanConstantFilterExpression Right )
Parameters
- Left
- Type: Tekla.Structures.FilteringBooleanFilterExpression
The left operand of the filter expression. - Oper
- Type: Tekla.Structures.FilteringBooleanOperatorType
The operator of the filter expression. - Right
- Type: Tekla.Structures.FilteringBooleanConstantFilterExpression
The right operand of the filter expression.
Exceptions
Exception | Condition |
---|---|
ArgumentNullException | Thrown when a null filter expression is specified. |
See Also