BaseRebarGroupRebarGroupSpacingTypeEnum Enumeration

The ways to distribute the reinforcing bars with different spacings.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public enum RebarGroupSpacingTypeEnum
Members
  Member nameValueDescription
SPACING_TYPE_UNDEFINED0 The undefined spacing type.
SPACING_TYPE_EXACT_SPACINGS1 The bars are distributed using the spacing values.
SPACING_TYPE_EXACT_NUMBER2 Equal distribution by the number of reinforcing bars.
SPACING_TYPE_TARGET_SPACE3 Equal distribution by the target spacing value.
SPACING_TYPE_EXACT_SPACE_FLEX_AT_START4 Distribution by the exact spacing value with a flexible first space.
SPACING_TYPE_EXACT_SPACE_FLEX_AT_END5 Distribution by the exact spacing value with a flexible last space.
SPACING_TYPE_EXACT_SPACE_FLEX_AT_BOTH6 Distribution by the exact spacing value with flexible first and last spaces.
SPACING_TYPE_EXACT_SPACE_FLEX_AT_MIDDLE7 Distribution by the exact spacing value with a flexible middle space.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next