Assertion Class |
Defines an assertion by the method it failed in and the messages it
provided.
Inheritance Hierarchy
Namespace: Tekla.Structures
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The Assertion type exposes the following members.
Constructors
Properties
Name | Description | |
---|---|---|
DetailedMessage |
Gets the detailed message provided by the assertion.
| |
Message |
Gets the message provided by the assertion.
| |
MethodName |
Gets the name of the method the assertion failed in.
|
Methods
Name | Description | |
---|---|---|
Equals |
The equals.
(Overrides ObjectEquals(Object).) | |
GetHashCode |
Gets a hash code for this instance.
Calculated as recommended at http://msdn.microsoft.com/en-us/library/system.object.gethashcode.aspx
(Overrides ObjectGetHashCode.) | |
ToString |
The tostring.
(Overrides ObjectToString.) |
See Also