ArrowheadAttributes Class |
The ArrowheadAttributes class handles attributes related to arrowheads of different objects.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingArrowheadAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingArrowheadAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The ArrowheadAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ArrowheadAttributes |
Creates a new default arrowhead attributes instance. The default values are ArrowheadPositions.None, ArrowheadTypes.FilledArrow, height 2.0 and width 1.0.
| |
ArrowheadAttributes(ArrowheadPositions, ArrowheadTypes, Double, Double) |
Creates a new arrowhead attributes instance with the given parameters.
|
Properties
Name | Description | |
---|---|---|
ArrowPosition |
The position of the arrowhead. The position is always ArrowheadPositions.Both for dimensions.
| |
Head |
The type of the arrowhead.
| |
Height |
The height of the arrowhead.
| |
Width |
The width of the arrowhead.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |
See Also