Arc Constructor (Point, Point, Vector, Double)

Constructs a new arc geometry

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public Arc(
	Point centerPoint,
	Point startPoint,
	Vector normal,
	double deltaAngleRadians
)

Parameters

centerPoint
Type: Tekla.Structures.Geometry3dPoint
Center point of the arc.
startPoint
Type: Tekla.Structures.Geometry3dPoint
StartPoint point of the arc.
normal
Type: Tekla.Structures.Geometry3dVector
Normal vector of the arc, defines the axis of rotation of the start vector.
deltaAngleRadians
Type: SystemDouble
Angle of the arc in radians. From 0 to 2*PI.
Exceptions
ExceptionCondition
ArgumentExceptionThrows when input values are not defined correctly
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next