![]() | Arc Constructor (Point, Point, Point) |
Constructs a new arc geometry
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63

Parameters
- startPoint
- Type: Tekla.Structures.Geometry3dPoint
Start point of the arc. - endPoint
- Type: Tekla.Structures.Geometry3dPoint
End point of the arc. - pointOnArc
- Type: Tekla.Structures.Geometry3dPoint
Point that defines the arc.

Exception | Condition |
---|---|
ArgumentException | Throws when input points are not defined correctly |