ApplicationFormBase Class |
The ApplicationFormBase class is the base class for all Tekla Structures dialogs.
The class provides localization, unit conversion and data storage
(temporary and file-based) among other things.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Tekla.Structures.DialogFormBase
Tekla.Structures.DialogApplicationFormBase
More...
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Tekla.Structures.DialogFormBase
Tekla.Structures.DialogApplicationFormBase
More...
Namespace: Tekla.Structures.Dialog
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The ApplicationFormBase type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ApplicationFormBase |
The default constructor that does not need parameters.
Initializes the form and registers property bindings.
|
Properties
Name | Description | |
---|---|---|
Localization |
The localization instance for the dialog. Each dialog has its own localization instance
that has read the localization files needed for that dialog.
(Inherited from FormBase.) |
Methods
Name | Description | |
---|---|---|
ApplyValues |
Loads the dialog values from a file and performs Apply on the loaded values.
To match the files to a certain dialog, the file suffix is set as the dialog type's name.
(Inherited from FormBase.) | |
GetConnectionStatus |
Returns true if a proper connection to the Tekla Structures process has been established.
Currently, there's no way to re-establish the connection.
(Inherited from FormBase.) | |
InitializeForm |
Prepares the data storage for the dialog and scans through the fields.
(Inherited from FormBase.) | |
LoadValues |
Loads the dialog values from a file. To match the files to a certain dialog,
the file suffix is set as the dialog type's name.
(Inherited from FormBase.) | |
ModifyValues |
Loads the dialog values from a file and performs Modify on the loaded values.
To match the files to a certain dialog, the file suffix is set as the dialog type's name.
(Inherited from FormBase.) | |
SaveValues |
Serializes the dialog values to an xml file.
(Inherited from FormBase.) | |
SetAttributeValue |
Sets a value for the given control. When the dialog is not shown, setting a property
directly for a control (such as textBox1.Text = "text") will not work for controls that
have a Tekla Structures AttributeTypeName set. This method is going to have to be used
to set the value.
(Inherited from FormBase.) | |
ShowForm |
Displays the form.
(Inherited from FormBase.) | |
UpdateValues | Obsolete.
Rereads and updates all the field values on the form.
(Inherited from FormBase.) |
See Also
Reference
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Tekla.Structures.DialogFormBase
Tekla.Structures.DialogApplicationFormBase
Tekla.Structures.Dialog.UIControlsCommitAction
Tekla.Structures.Dialog.UIControlsCreateDialog
Tekla.Structures.Dialog.UIControlsMeshSelectionForm
Tekla.Structures.Dialog.UIControlsOrganizerDialog
Tekla.Structures.Dialog.UIControlsPropertiesDialog
Tekla.Structures.Dialog.UIControlsTreeViewDialog
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Tekla.Structures.DialogFormBase
Tekla.Structures.DialogApplicationFormBase
Tekla.Structures.Dialog.UIControlsCommitAction
Tekla.Structures.Dialog.UIControlsCreateDialog
Tekla.Structures.Dialog.UIControlsMeshSelectionForm
Tekla.Structures.Dialog.UIControlsOrganizerDialog
Tekla.Structures.Dialog.UIControlsPropertiesDialog
Tekla.Structures.Dialog.UIControlsTreeViewDialog