PolycurveGeometryBuilderAppendTangentSegment Method

Appends a line segment of the given length tangent to the last curve of the list.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public PolycurveGeometryBuilder AppendTangentSegment(
	double length
)

Parameters

length
Type: SystemDouble
Length of the segment to append

Return Value

Type: PolycurveGeometryBuilder
The builder itself
Remarks
This function requires that there is at least one curve in the polycurve
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next