![]() | AngleDimensionAttributes Class |
The AngleDimensionAttributes class contains the attributes for angle dimensions.
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingAngleDimensionAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingAngleDimensionAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
The AngleDimensionAttributes type exposes the following members.
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
Name | Description | |
---|---|---|
![]() | AngleDimensionAttributes |
Creates a new angle dimension attributes instance which loads standard attributes.
|
![]() | AngleDimensionAttributes(String) |
Creates a new angle dimension attributes instance that loads the specified attributes.
|
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
Name | Description | |
---|---|---|
![]() | Arrowhead |
The arrowhead attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) |
![]() | Color |
The color of the dimension line.
(Inherited from DimensionSetBaseAttributes.) |
![]() | Format |
The format attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) |
![]() | Placing |
The placing attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) |
![]() | Text |
The text attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) |
![]() | TransparentBackground |
The dimension text background transparency. (transparent/opaque)
(Inherited from DimensionSetBaseAttributes.) |
![]() | TriangleBase |
Gets or sets the triangle base length which controls the base dimension
shown for bevel dimensions (only if Type is AngleTypes.Triangle).
|
![]() | TrueColor |
The true color (RGB enabled) of the dimension line.
(Inherited from DimensionSetBaseAttributes.) |
![]() | Type |
The type of the angle.
|
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) |
![]() | LoadAttributes |
Loads attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
using Tekla.Structures.Drawing; public class Example { public void Example1() { AngleDimensionAttributes attributes = new AngleDimensionAttributes("MyAttributes"); } }
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)