AnalysisVolumeItem Class

The AnalysisVolumeItem class contains information related to analysis volume items.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public sealed class AnalysisVolumeItem : AnalysisObject

The AnalysisVolumeItem type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisVolumeItem
Initializes a new instance of the AnalysisVolumeItem class
Top
Properties
  NameDescription
Public propertyAnalysisModelName
Gets or sets the analysis model name.
(Inherited from AnalysisObject.)
Public propertyAnalysisObjectType
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.)
Public propertyFaces
The faces of the analysis volume item.
Public propertyFatherObject2ID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObject2Type
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyFatherObjectID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObjectType
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyID
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.)
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next