AnalysisResultResultPositionEnum Enumeration |
The result position.
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
POSITION_BY_COORDINATES | 0 | The position given by the coordinates X, Y and Z. | |
POSITION_BY_COORDINATES_MINUS | 6 | The position given by the coordinates X, Y and Z (minus side). | |
POSITION_BY_COORDINATES_PLUS | 7 | The position given by the coordinates X, Y and Z (plus side). | |
POSITION_BEAM_START_POINT | 1 | The member start position. | |
POSITION_BEAM_END_POINT | 2 | The member end position. | |
POSITION_BEAM_MID_POINT | 3 | The member middle position. | |
POSITION_BEAM_MID_POINT_MINUS | 4 | The member middle position (minus side). | |
POSITION_BEAM_MID_POINT_PLUS | 5 | The member middle position (plus side). | |
POSITION_MAX_NO_COORDINATES | 201 | No position specified, gets the maximum. | |
POSITION_MIN_NO_COORDINATES | 203 | No position specified, gets the minimum. |
See Also