AnalysisPartAreaAttributes Class |
The AnalysisPartAreaAttributes class contains information related to analysis part area attributes.
Inheritance Hierarchy
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The AnalysisPartAreaAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
AnalysisPartAreaAttributes | Initializes a new instance of the AnalysisPartAreaAttributes class |
Properties
Name | Description | |
---|---|---|
AreaElementSizeHoles |
Gets or sets the area element size holes.
| |
AreaElementSizeX |
Gets or sets the area element size X.
| |
AreaElementSizeY |
Gets or sets the area element size Y.
| |
AreaElementType |
Gets or sets the area element type.
| |
AreaRotationXY |
Gets or sets the area rotation XY.
| |
AreaStartNumber |
Gets or sets the start number of the area.
| |
AreaSupport | Obsolete.
Gets or sets the area support.
| |
AreaSupportType |
Gets or sets the area support type.
| |
MinimumAreaHoleSize |
Gets or sets the minimum area hole size.
| |
RigidDiaphragmFilterName |
Gets or sets the filter name of the rigid diaphragm.
| |
UseSimpleArea |
Gets or sets a value indicating whether simple areas are used.
|
See Also