AnalysisObjectPicker Class

The AnalysisObjectPicker class can be used to prompt the user to do manual picks of analysis objects. The methods throw an exception if the user interrupts (cancels) the pick command.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Analysis.UIAnalysisObjectPicker

Namespace:  Tekla.Structures.Analysis.UI
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public class AnalysisObjectPicker

The AnalysisObjectPicker type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisObjectPicker
Initializes a new instance of the AnalysisObjectPicker class
Top
Methods
  NameDescription
Public methodPickObject
Prompts the user to pick object from the model with the given prompt. Object is either analysis object or model object.
Public methodPickObjects
Prompts the user to pick objects from the model with the given prompt.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next